Log of the #fcrepo channel on chat.freenode.net

Using timezone: Eastern Standard Time
* awead joins06:59
* dwilcox joins07:27
* awead leaves07:56
* awead joins08:04
* mhwood joins08:23
* awead leaves08:34
* dhlamb joins08:38
* awead joins08:42
* awoods joins09:23
* ajs6f joins09:26
* awoods leaves09:38
* awoods joins09:50
* whikloj joins10:05
* awoods leaves10:25
* awoods joins10:34
* dwilcox leaves10:46
* awoods_ joins11:31
* awoods leaves11:32
* rarian leaves11:36
* ajwagner joins11:38
* awead_away leaves12:00
* ksclarke joins12:01
* dwilcox joins12:24
* awead joins12:36
* ajs6f leaves12:43
* github-ff joins12:44
[fcrepo4] ajs6f created FCREPO-1411 (+1 new commit): http://git.io/vmkhl
fcrepo4/FCREPO-1411 a2f5259 ajs6f: Working implementation of FCREPO-1411
* github-ff leaves
* mhwood leaves
* travis-ci joins12:57
fcrepo4/fcrepo4#3818 (FCREPO-1411 - a2f5259 : ajs6f): The build passed.
Change view : https://github.com/fcrepo4/fcrepo4/commit/a2f52597a2ae
Build details : https://travis-ci.org/fcrepo4/fcrepo4/builds/70767885
* travis-ci leaves
<whikloj>awoods: ping13:43
<awoods>on a call13:45
but wrapping up
<whikloj>awoods: ok
* acoburn joins13:49
awoods: ping
<awoods>on a call13:50
<whikloj>anyone else tell me how I would test if a Resource is a blank node?13:51
<acoburn>whikloj: https://github.com/fcrepo4/fcrepo4/blob/master/fcrepo-kernel-impl/src/main/java/org/fcrepo/kernel/impl/utils/FedoraTypesUtils.java#L8213:53
<whikloj>acoburn: does that only work as a filter? I am testing inside of a Predicate filter already and I'm not sure if that is "best practice"13:58
acoburn: forget it I think I see an example13:59
<acoburn>whikloj: np14:00
<awoods>acoburn: back
<acoburn>awoods: at last week's tech call, we didn't get to the item about renaming the fcrepo-kernel modules14:01
awoods: I won't be there this week, but I had an opinion to contribute
awoods: I really like the idea of moving fcrepo-kernel -> fcrepo-kernel-api14:02
awoods: but I'm not sure about fcrepo-kernel-impl -> fcrepo-kernel
<awoods>acoburn: do you want to leave fcrepo-kernel-impl alone?
<acoburn>awoods: I'd be happier if it was something like fcrepo-kernel-jcr
awoods: no, it shouldn't have "impl" in it
awoods: that's the point, standard practice is that OSGi bundles don't export any packages with "impl" in their name14:03
awoods: as long as it's fcrepo-kernel-<something>, I'd be happy (so long as <something> isn't "impl")14:05
<awoods>acoburn: sounds good. Feel free to add any comments/notes to: https://wiki.duraspace.org/display/FF/2015-07-16+-+Fedora+Tech+Meeting
<acoburn>awoods: will do14:06
<ruebot>awoods: i'm back from self imposed exile. around if we need to catch up on any release related stuff.14:14
* ajs6f joins14:18
acoburn: +1 to fcrepo-kernel-jcr. That also makes the point that people are welcome to cut a fcrepo-kernel-your-favorite-nosqldb or fcrepo-kernel-transparent-filesystem or whatever.14:21
<awoods>ruebot: welcome back. Let's touch base closer to the end of the week to see where the code stands... so far, we look good to target releasing next week.
<ruebot>awoods: sounds like a plan.14:22
<acoburn>ajs6f: that's exactly what I had in mind with that naming convention
<ajs6f>acoburn: I'm pretty sure that we actually called it fcrepo-kernel-api at first, but somehow it got changed. Probably awoods' fault, somehow.14:23
<escowles>ajs6f: acoburn: IIRC, we wanted to keep the api class names shorter, and it was easier to rename the impl. classes b/c they were used in fewer places14:31
<ajs6f>escowles: in hindsight, that does not sound like good reasoning.14:32
<escowles>ajs6f: well, we didn't have any good reason to favor one over the other, so we went with the lazier option -- too bad we didn't know it would be an issue later on14:33
<ajs6f>escowles: Oh, it's not an issue. It's acoburn's issue.
<acoburn>ajs6f: escowles: my thought is that this makes a clearer separation between the api and the implementation14:36
my main concern is the naming of fcrepo-kernel-impl14:37
<escowles>acoburn: i'm happy with fcrepo-kernel-api and fcrepo-kernel-jcr/modeshape/whatever14:38
<ajs6f>acoburn:escowles: escowles makes a good point. The current kernel-impl depends on MODE-specific stuff.
<acoburn>ajs6f: I really don't care if it's fcrepo-kernel-modeshape or fcrepo-kernel-jcr14:39
<ajs6f>acoburn: Then use fcrepo-kernel-modeshape
<acoburn>ajs6f: I'll adjust the proposal then14:40
<escowles>fcrepo-kernel-modeshape++ # we definitely depend on mode-specific stuff, so that's more accurate than -jcr
<ajs6f>acoburn: Adjust the hell out that proposal!
<acoburn>ajs6f: done
<ajs6f>BOOOM!14:41
<awoods>escowles/acoburn/ajs6f: as a general note, I think the principle of maintaining correlation between the project name (fcrepo-kernel-modeshape) and the package name (org.fcrepo.kernel.modeshape) is clear and clean. Is that a shared opinion?14:58
<acoburn>awoods: I would agree with that14:59
<ajs6f>awoods: I won't stop you.
* ksclarke leaves
<awoods>escowles/acoburn/ajs6f: just checking15:00
<escowles>awoods: +1
<ajs6f>If we're going to thrash namespaces, we should do it as soon as possible. It only gets harder with time.15:01
<awoods>ajs6f: between fcrepo-kernel-* and the fcrepo4-exts projects, we are looking at a namespace thrashing hoedown.15:04
<ajs6f>Hoe them namespaces! Thrash them kernels!
<awoods>afk - hoeing down to the post office15:10
* ksclarke joins15:14
* ksclarke leaves
* dwilcox leaves15:16
* github-ff joins15:25
[fcrepo4] ajs6f pushed 1 new commit to FCREPO-1411: http://git.io/vmL3M
fcrepo4/FCREPO-1411 766f392 ajs6f: DRYing up tests for subject appropriateness
* github-ff leaves
* github-ff joins15:26
[fcrepo4] ajs6f opened pull request #836: https://jira.duraspace.org/browse/FCREPO-1411 (master...FCREPO-1411) http://git.io/vmLse
* github-ff leaves
* github-ff joins15:31
[fcrepo4] acoburn opened pull request #837: fixed minor typo (master...fcrepo-1633) http://git.io/vmLZk
* github-ff leaves
* travis-ci joins15:37
fcrepo4/fcrepo4#3821 (FCREPO-1411 - 766f392 : ajs6f): The build passed.
Change view : https://github.com/fcrepo4/fcrepo4/compare/a2f52597a2ae...766f392e38e1
Build details : https://travis-ci.org/fcrepo4/fcrepo4/builds/70791765
* travis-ci leaves
* tolloid joins15:51
* ksclarke joins16:03
* ksclarke leaves
* ksclarke joins16:07
* ksclarke leaves
* dhlamb leaves16:10
* ksclarke joins16:11
* github-ff joins16:14
[fcrepo4] ajs6f pushed 2 new commits to master: http://git.io/vmLw5
fcrepo4/master 550154e Aaron Coburn: fixed minor typo
fcrepo4/master beb029c A. Soroka: Merge pull request #837 from acoburn/fcrepo-1633...
* github-ff leaves
* awead leaves16:26
* travis-ci joins16:29
fcrepo4/fcrepo4#3825 (master - beb029c : A. Soroka): The build passed.
Change view : https://github.com/fcrepo4/fcrepo4/compare/4c4e1c3b59f0...beb029c9fb3c
Build details : https://travis-ci.org/fcrepo4/fcrepo4/builds/70798873
* travis-ci leaves
* dwilcox joins16:31
* github-ff joins16:42
[fcrepo4] acoburn opened pull request #838: invert logic for clarity (FCREPO-1411...fcrepo-1411-negate_logic) http://git.io/vmLyQ
* github-ff leaves
* dwilcox leaves
* github-ff joins16:43
[fcrepo4] ajs6f closed pull request #838: invert logic for clarity (FCREPO-1411...fcrepo-1411-negate_logic) http://git.io/vmLyQ
* github-ff leaves
* awoods leaves16:45
* acoburn leaves
* travis-ci joins16:56
fcrepo4/fcrepo4#3829 (FCREPO-1411 - 44354d4 : A. Soroka): The build passed.
Change view : https://github.com/fcrepo4/fcrepo4/compare/766f392e38e1...44354d4429e2
Build details : https://travis-ci.org/fcrepo4/fcrepo4/builds/70803370
* travis-ci leaves
* tolloid leaves
* ajs6f leaves
* awoods joins16:59
* awead joins17:11
* github-ff joins17:36
[fcrepo4] awoods pushed 3 new commits to master: http://git.io/vmtk3
fcrepo4/master e613e6b Aaron Coburn: reimplemented org.modeshape/modeshape-jcr/value/* classes...
fcrepo4/master fabb0cc Aaron Coburn: removed org.modeshape.jcr.IsExternal class
fcrepo4/master 1c0156c Aaron Coburn: Remove DistributedFixityCheck; reimplemented GetBinaryStore...
* github-ff leaves
* github-ff joins17:38
[fcrepo4] awoods closed pull request #834: Remove org.modeshape.jcr hacks (master...fcrepo-1535) http://git.io/vqFDd
* github-ff leaves
* awead leaves17:42
* whikloj leaves17:48
* dwilcox joins17:53
* dwilcox leaves18:09
* dwilcox joins18:13
* dwilcox leaves18:22
* ksclarke leaves18:28
* ksclarke joins19:51
* awoods_ joins19:54
* awoods__ joins19:56
* awoods leaves19:57
* awoods_ leaves20:00
* awoods_ joins20:15
* awoods__ leaves20:19
* escowles leaves20:36
* awead joins20:42
* dwilcox joins20:43
* dhlamb joins21:11
* awoods__ joins21:46
* awoods_ leaves21:49
* awoods_ joins22:03
* awoods__ leaves22:06
* awoods__ joins22:09
* awoods_ leaves22:12
* dhlamb leaves
* awoods_ joins
* awoods__ leaves22:16
* awoods__ joins22:18
* awoods_ leaves22:22
* awoods_ joins22:23
* awoods__ leaves22:26
* dwilcox leaves22:28
* awoods__ joins22:48
* awead leaves22:50
* awoods_ leaves22:51
* awoods_ joins23:14
* awoods joins23:17
* awoods__ leaves23:18
* awoods_ leaves23:19
* awead joins23:48
* awoods_ joins00:48
* awoods leaves00:51
* awead leaves00:59
* ksclarke leaves01:39

Generated by Sualtam